Rownd - Token API delays – Incident details

Token API delays

Resolved
Degraded performance
Started almost 2 years agoLasted about 3 hours

Affected

API

Degraded performance from 10:10 AM to 1:10 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    Beginning at approximately 10:10 UTC, the Rownd token API began experiencing increased latency. Authenticated users may have felt impacts due to timeouts when attempting to refresh an access token that had expired.

    The root cause was identified and tracked to a non-critical, downstream, third-party component failure.

    A fix was implemented to bypass the downstream component in the event of failure, which would resolve the issue and prevent it from recurring.

    The fix was deployed at approximately 13:00 UTC and token refresh response times began to improve immediately.

    We are monitoring the situation throughout the day to ensure that the API continues to operate as expected.

  • Identified
    Identified

    We've identified the root issue that is delaying or preventing token refreshes from client SDKs on the web and mobile devices.

    We are working on a fix for this incident.

  • Investigating
    Investigating

    Authenticated users are experiencing delays when opening apps, visiting websites, etc. In some cases, they are being signed out, though they are able to sign in successfully after the fact.

    We are currently investigating this incident.