Rownd - Rownd API intermittently failing – Incident details

Rownd API intermittently failing

Resolved
Major outage
Started 12 days agoLasted 19 minutes

Affected

Platform

Major outage from 1:09 AM to 1:28 AM

API

Major outage from 1:09 AM to 1:28 AM

Updates
  • Postmortem
    Postmortem

    We take any amount of downtime very seriously, and we want to provide full transparency regarding our recent service interruption. We sincerely apologize for the inconvenience this caused to you and your users.

    • Root Cause: During a routine auto-rotation of our internal certificates, an unexpected race condition occurred. This caused the certificate trust chain to break between our internal service members, leading to the outage.

    • Resolution: Our engineering team quickly identified the issue, manually recycled the necessary certificates, and restarted the affected services. All systems have successfully recovered and are operating normally.

    • Preventative Measures: To ensure this does not happen again, we are implementing configuration changes to our infrastructure prior to our next scheduled certificate rotation. These updates will strictly enforce the proper rotation sequence and guarantee that certificates cannot fall out of sync.

  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.